Database Programming  Tutorial 1 
Getting Started with ADO.NET 

In this tutorial exercise you will learn how to:

· Use Server Explorer to establish a connection to a database.

· Create a data adapter that extracts specific database information.

· Create a dataset to represent one or more database tables in your program.

· Use TextBox, Label, and Button controls to display database information and navigation controls on a Windows Form.

In this tutorial exercise you’ll learn how to work with information stored in databases. You’ll learn about ADO.NET, Microsoft’s newest paradigm for working with database information, and you’ll learn how to display, modify, and search for database information by using a combination of program code and Windows Forms controls. MicrosoftVisual Basic .NET was specifically designed to create custom interfaces, or front ends, for existing databases, so if you’d like to customize or dress up data that you’ve already created with another application, such as Microsoft Access, you can get started immediately.

In this text, you’ll take your first steps with ADO.NET database programming. You’ll use the Server Explorer window to establish a connection to an Access database on your system, you’ll configure the connection by using the Data Link Properties dialog box, you’ll use a data adapter to select the data table that you want to use, and you’ll create a dataset based on the table that will represent a portion of the database in your program. After you’ve completed these preliminary steps, you’ll use the TextBox, Label, and Button controls to display database information on a Windows Form.
Database Programming with ADO.NET 

A database is an organized collection of information stored in a file. You can create powerful databases by using any of a variety of database products, including Microsoft Access, Microsoft FoxPro, Btrieve, Paradox, Oracle, and Microsoft SQL Server. You can also store and transmit database information by using XML (Extensible Markup Language), a file format designed for exchanging structured data over the Internet and in other settings.

Creating and maintaining databases has become an essential task for all major corporations, government institutions, non-profit agencies, and most small businesses. Rich data resources—be they customer addresses, manufacturing inventories, account balances, employee records, donor lists, or order histories—have become the lifeblood of the business world.

Microsoft Visual Basic .NET isn’t designed for creating new databases, but rather for displaying, analyzing, and manipulating the information in existing databases. Although previous versions of Visual Basic have also provided this capability, Visual Basic .NET offers a new data model called ADO.NET that provides access to an even greater number of database formats. In particular, ADO.NET has been designed for Internet use, meaning that it uses the same method for accessing local, client-server, and Internet-based data sources. As a testimony to Microsoft’s goal of making ADO.NET a great technology for manipulating databases over the Internet, Microsoft has made XML—a standard defined by the World Wide Web Consortium—the internal data format of ADO.NET. Using XML in this way makes ADO.NET easier to utilize with existing Internet data sources, and it makes it easier for software vendors to write data adapters, or “providers,” that convert third-party database formats to be compatible with ADO.NET.

Database Terminology 

When working with databases and ADO.NET, it’s important to understand some basic database terminology. Fields are the categories of information stored in a database. Typical fields in a customer database might include customer names, addresses, phone numbers, and comments. All the information about a particular customer or business is called a record. When databases are created, information is entered in tables of fields and records. Records correspond to rows in a table, and fields correspond to columns, as shown here:
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In ADO.NET, various objects are used to retrieve and modify information in a database. The following illustration shows an overview of the approach that will be covered in more detail in this tutorial:
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First a connection is made, which specifies connection information about the database. Next a data adapter is created, which manages retrieving data from the database and posting data changes. Then a dataset is created, which is a representation of one or more database tables you plan to work with in your program. (You don’t manipulate the actual data, but rather a copy of it.) Information in the dataset can then be bound to controls on a form.

Working with an Access Database 

In the following sections, you’ll learn how to use the ADO.NET data access technology in Visual Basic .NET. You’ll get started by using Server Explorer to establish a connection to a database named Students.mdb that I created in Microsoft Access. Students.mdb contains various tables of academic information that would be useful for a teacher who’s tracking student coursework or a school administrator who’s scheduling rooms, assigning classes, or building a time schedule. You’ll learn how to create a dataset based on a table of information in the Students database, and you’ll display this information on a Windows Form. When you’ve finished, you’ll be able to put these skills to work in your own database projects.

TIP 
Although the sample in this text uses a Microsoft Access database, you don’t have to have Microsoft Access installed. Visual Studio and ADO.NET include the necessary support to understand the Access file format as well as other formats.

We will create a new folder for our ADO application and store the database we wish to connect with, in that folder. In the example which follows the folder used is c:\vbnet03sbs\chap19. Note that you can put your project anywhere you wish. However, if you do so you will need to modify the pathnames given in this tutorial appropriately. So, for example, if you decide to create your project in c:\VbDb\DBTut1 folder, you should use this as the pathname throughout this tutorial, and ensure that this is where you place the database before you begin. The database used for this tutorial is Students.mdb and this is available from the appropriate link on the COM622M1 Web Pages under Database Tutorial 1.
Establish a connection to a database

1. Start Visual Studio .NET, and create a new Visual Basic Windows Application project named My ADO Form in the c:\vbnet03sbs\chap19 folder. 
A new project appears in the development environment.

2. On the View menu, click the Server Explorer command.

The Server Explorer window appears in the development environment, as shown here:
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TIP 
Depending on your configuration and edition of Visual Studio, the Connect To Server button and the Servers node might not be displayed. These options aren’t required to complete the steps in this tutorial.

Server Explorer is a graphical tool that lets you establish connections to local, client-server, or Internet-based data sources. Using Server Explorer, you can view the structure of database tables and learn more about the attributes of tables, fields, and records in a database. You can also log on to network servers and explore the databases and system services that they offer. Finally, you can drag database components, or nodes, from Server Explorer and drop them onto Visual Studio .NET designers, such as the Windows Forms Designer. This process creates new data components that are preconfigured to reference the database item you selected.

3. Click the Connect To Database button in Server Explorer.

Before you can manipulate the information in a database, you need to establish a connection to it. The Connect To Database button begins that process by opening the Data Link Properties dialog box, which lets you specify information about the database format, the database location and password (if necessary), and other information.

TIP 
You can also open the Data Link Properties dialog box by clicking the Connect To Database command on the Tools menu.

4. Click the Provider tab in the dialog box.

A provider (or managed provider) is an underlying database component that knows how to connect to a database and extract data from it. The two most popular types of providers offered by Visual Studio .NET are OLE DB and SQL, but there are also third-party providers available for many of the most popular database formats. In this example, you’ll use the Microsoft Jet 4.0 OLE DB provider, a component designed to connect to Microsoft Access databases.

5. Click Microsoft Jet 4.0 OLE DB Provider on the Provider tab.

Your screen will look like this:

[image: image4.png]& Data Link Properties

Provide | Comecton | Advanced | A1 |

Selectthe data you want to comnect to

0LE DB Providers]

MedaCatalogDB DLE DE Provider
MedaCataloghergedDB OLE DB Frovider
MedaCalalogiy/ebDB DLE DB Provider
Hic TLE DE Provider
Microsaft OLE DB Pravider Far Data Mining Services
Microsaft OLE DB Provider forIndesing Service.
Mictosaft OLE DB Provider for Inernet Publishing
Microsaft OLE DB Provider for ODBC Diivers
Microsaft OLE DB Provider for OLAP Services 8.0
Microsaft OLE DB Provider for Oracle

Mictosoft OLE DB Provider for STIL Server

Mictosaft OLE DB Simple Provider

MSDataShape

OLE DB Provider fr Mictosolt Direstary Services

==





[image: image5]
6. Click the Next button to display the Connection tab of the Data Link Properties dialog box.

Because you selected a Jet OLE DB format, which is the internal format of Microsoft Access, the Connection tab has been configured to receive information about the name, location, and logon information of an Access database.

7. Click the ellipsis button next to the Select Or Enter A Database Name field, select the Students.mdb database in the                           c:\ vbnet03sbs\chap19 folder, and then click Open.

Your screen will look like this:
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TIP 
You can specify your own database if you like, but you’ll need to modify the steps in this chapter accordingly to fit your database’s structure. (Best stick with this example until you are moreexperienced).
8. Click the Test Connection button on the Connection tab.

Visual Studio attempts to establish a database connection with the Students.mdb database. If the message “Test Connection Succeeded” appears in a message box, you know the provider is working properly and that your database is structured in a recognizable format. If Visual Studio detects a problem at this point, verify that you’re using an appropriate provider and that you selected a database file, and then try the connection again.

9. Click OK in the Test Connection Succeeded message box to continue, and then click OK in the Data Link Properties dialog box.

Visual Studio completes your connection and adds a node representing your database to Server Explorer.

10. Open the Data Connections node, the ACCESS node, and finally the Tables node in Server Explorer.

To open nodes in Server Explorer, click the plus signs (+), which function as toggle switches. The structure of the Students database appears in Server Explorer, as shown here:
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Server Explorer provides this great advantage: it lets you see how a database is organized graphically so that you can immediately make use of its tables, fields, and other objects.

Creating a Data Adapter 

Now that you have an active database connection, you need to create a data adapter to extract specific information from the database for your program to use. A data adapter defines the specific information you’ll use and serves as a foundation for the dataset object, which is the representation of the data you want to use in your program. Creating a data adapter is a required step when using a dataset because some databases are highly structured and have many tables to choose from—much more than you might want to make use of in a single program. You might think of a data adapter as a kind of filter for the data.

Visual Studio provides several mechanisms for creating data adapters in a program. The easiest way is to simply drag a graphical table icon from Server Explorer to the Windows Forms Designer. (This procedure creates a data adapter object in the component tray directly below the form.) However, the following exercise shows you how to create a data adapter by using a second method—a tool called the Data Adapter Configuration Wizard. This tool is easy to use, and it gives you the opportunity to fine-tune your data selection by writing a SQL SELECT statement. You launch the wizard by dragging the OleDbDataAdapter control from the Data tab of the Toolbox onto a form. Give this second method a try now.

Use the OleDbDataAdapter control

1. Open the Toolbox, and click the Data tab.

The Data tab contains controls that help you access data in your programs.You access data by adding a data adapter object and a dataset object to your program’s component tray.

TIP 
The OleDbConnection and SqlConnection controls can also be used to establish a connection between your program and a data source on a local computer, network server, or Internet resource. However, you already created a database connection using Server Explorer in this chapter, so using the OleDbConnection control isn’t necessary now.

2. Drag the OleDbDataAdapter control from the Data tab of the Toolbox to the form.

The OleDbDataAdapter control is designed to handle connections to Access/Jet databases and many other popular database formats. When you drag the control to your form, Visual Studio starts the Data Adapter Configuration Wizard. (Be patient: It may take a second or two: There is a lot of processing happening here!)
3. Read the opening statement about data adapters, and then click Next.

The second wizard dialog box appears, prompting you for the name of a valid data adapter. Your screen should look like this:
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Because you already created a data connection to an Access database by using Server Explorer, the connection appears in the drop-down list box. (If you hadn’t created the connection or wanted to create a new one, you could do so now by clicking the New Connection button.)

4. Click Next to continue configuring the data adapter.

You’ll see the following dialog box asking you how the data adapters should access data in the database:
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The first option, Use SQL Statements, gives you the opportunity to create a SQL SELECT statement that will fine-tune, or filter, the data you plan to use. For Visual Basic users who are familiar with database programming, writing Access queries, or using SQL Server, creating a SQL SELECT statement is relatively straightforward. If you’re not familiar with this syntax, however, you can use the Query Builder tool to visually generate an appropriate SELECT statement. We’ll use the Query Builder in the following steps.

5. Click Next to accept the Use SQL Statements option.

You’ll see the following dialog box, which prompts you for a valid SQL SELECT statement:
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6. Click the Query Builder button to build your SELECT statement graphically.

The Add Table dialog box appears, as shown next:
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To build your SELECT statement, you need to pick one or more tables provided by the Students.mdb database.

7. Click Instructors, click Add, and then click Close.

Visual Studio displays the graphical Query Builder tool, which now contains a representation of the Instructors table.

8. In the Instructors table, click the check boxes next to the Instructor and InstructorID fields.

The Query Builder creates a SELECT statement that extracts the Instructor and InstructorID fields from the Instructors table, as shown here:
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In this example, you’re just extracting two fields from the table, but you can easily create a SQL SELECT statement that extracts several fields from one or more tables. The InstructorID field is shown in bold type because it’s acting as the primary key for the database table.

9. Click OK to complete the SELECT statement.

The Generate The SQL Statements dialog box reappears with your new SELECT statement. (You might want to remember this simple syntax—you can use it to write your own SELECT statements without using the Query Builder in the future.)

10. Click the Finish button.

If you see a dialog box prompting you for password information, click Don’t Include Password. Visual Studio adds the completed data adapter to the component tray beneath your form. Visual Studio also adds a representation of the OleDbConnection object to the component tray. Each object is identified by a unique number because you can have more than one data connection or data adapter in a project. Your screen looks like this:
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Working with Datasets 

The next step in ADO.NET database programming is creating an object that represents the data you want to use in your program. As I mentioned earlier, this object is called the dataset, and it’s a representation of the data provided by the data connection object and extracted by the data adapter object. A dataset can contain information from one or more database tables, and the contents can also be the result of a SQL SELECT statement, like the one you just used to extract data from the Students.mdb database. Unlike recordsets, the mechanisms for accessing data in previous versions of Visual Basic, datasets only represent the data in a database—when you modify a dataset, you don’t actually modify the underlying database tables until you issue a command that writes your changes back to the original database.                (Note that under some circumstances this could be problematic. Can you think why? Don’t wory if you can’t. This will be discussed in the lectures.)
In the following exercise, you’ll create a dataset that represents the Instructor field of the Instructors table in the Students.mdb database. As you’ll see, creating a dataset is easy once you have a properly configured data adapter to build on.

Create a dataset to hold Instructor data

1. Click the form to make sure that it’s active.

If the form doesn’t have the focus, the command you need to create a dataset isn’t available on the Data menu.

2. Click the Generate Dataset command on the Data menu. (The Data menu at the top opf the screen that is. Note that option Generate Dataset may also appear in a little box underneath the Properties window at the bottom right-hand of the screen).
The Generate Dataset dialog box appears.

3. In the New box, set the name of the new dataset to DsInstructors.
4. Verify that the Add This Dataset To The Designer check box is selected so that Visual Studio will add the new dataset to the component tray.

Your dialog box will look like this:
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5. Click OK to create a dataset for the Instructor field and add it to your project.

The dataset appears in the component tray, as shown here:

[image: image18.png]0 St 400 Fr (L projc)
& (2 A0 o

[
ol

" R usenitrios

- Peferences

slnstructerst 890 fornDsind,

e S e M B
Mlowo = m (B as

B
H: =
s ERER
£ RIS
- L
H.: =
&wn =

!

s
Hodntnctrst

e

B

T Ctoiontyen §y0tGaedont E

o Tk

«EHAFSEFHEH

| - mwww.w nﬁ““wm.W““.ﬂ““,ﬂ«.m“.ﬂ““,ﬂ«.ﬂ.ﬂ«,@.ﬂ.ﬂv,

s E5hi% .

e

|

Tkt

Hes

T

tert




Visual Studio also adds a file named DsInstructors.xsd to Solution Explorer that represents the database schema you just added to your project. This schema is an XML file that describes the tables, fields, data types, and other elements in the dataset. Typed datasets have a schema (.xsd) file associated with them, but un-typed datasets don’t. Typed datasets with schema files are advantageous because they enable the statement completion feature of the Visual Studio Code Editor, and they give you specific information about the fields and tables you’re using.

Now that you’ve created a dataset, you’re ready to display the records from the Instructors table on your form by using bound controls.

This is the subject of the next Tutorial: DBTut2.doc.
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